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PROJECT COMMANDER – PLANNING SOFTWARE

www.projectcommander.co.uk 

Introduction

There are several new improvements in this version ..

1. We have continued to improve the feature that opens Microsoft Project MPP files. Due to some of the funnies in MS Project, we cannot guarantee 100% that we can open any mpp file, but the majority of straightforward files will be ok. If you have a problem or you think there are any errors, please email the mpp file to us at office@pmscsolutions.co.uk and we are happy to either update our software or to convert the mpp file to a .pc file ourselves.

You should always ask people that send you a hard copy of a mpp file as well as the electronic file and you should check that the data transferred into Project Commander is identical to the original in Microsoft Project.

2. The INI file is now installed in the default directory – this makes security easier to set for Systems Administrators/IT Departments.

3. You can attach unlimited comments to a task and view/print them.

4. Where you update the plan, you can set alert dates that will pop up every time you open a file, if they are early/late starting/ending.

5. Using CONTROL CLICK, you can select random task rows in order to perform a procedure (eg shift project, linking, changing bar colours).

6. An on-screen only network diagram has been included and using a Task form in a window below. It will show all links input on the barchart using the mouse or via the link list. The network diagram view will allow you to change, add and delete links using the task form.

7. For users where several people access the file to update it, there is a change log file – where each user can record the changes made. It may be useful for single users that wish to keep an audit trail of changes to the file.

8. You can enter risks and issues in separate logs and these are saved with the file. The risks and issues can be allocated to one or several tasks and updated, until resolved. This is very useful for companies using Prince2 – as the risks/issues can be stored with the plan.

9. There is a new Info column that shows if there are any comments, risks, issues, date constraints or alerts appertaining to any task – using a small coloured triangle.

10.  For multi project users, the way to set up the client tied to a project has changed.

11. We have included a new TASK LIST view that allows you to enter a list of tasks (up to 999) with no paging.
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Modifications

· INI file  (pcprov65.ini) – user default settings

For stand-alone users, the .ini file (which contains your default settings) on previous versions was installed in c:\windows. The .ini file is now installed into the folder where Project Commander is installed (default c:\pc). Therefore, users with security on their pc, only need to have full read/write access to one folder (eg c:\pc).

If ever you need to restore the original defaults, there is a copy of the original installed ini file in the folder.

· Resource sheet
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The Resource Sheet is now a view and has no X on the top right window to close. It will close if another view or report is selected.

· View menu

There are several new items ..

Risk/Issues

Change log

Network diagram

Alerts

Show/Hide

Details are contained later in the document.

· Links

When you click on the Critical Path calculator icon in the Toolbar, there are now 2 further options. You can colour links between critical bars in red and any links that have a lag in blue. If both boxes are ticked any lagged links will be overridden by red.
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· Multi project – Project & Client

The project and client are now entered using the Tools menu, Projects.

Toolbar icons
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There are 2 new icons on the right 
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This will hide links and associated text (for off-page and hidden tasks). You re-click to display again.
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  Display the Information column in the current view. You re-click to hide again. 

Information icon
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There are 4 different positions for coloured triangles placed at each corner of the Information cell …

	Position
	Feature
	Colour

	Top left
	COMMENTS
	yellow

	Bottom left
	Fixed DATE CONSTRAINT
	red

	Bottom left
	Unfixed DATE CONSTRAINT
	blue

	Top right
	RISK
	red

	Bottom right
	ISSUE
	blue


A yellow triangle in the top left hand corner shows that a Comment is present on that row.

A red or blue triangle in the bottom left hand corner shows that a Date constraint is present on that task (Date constraints are input using the View menu, Task Form – Links, constraints TAB)
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A red triangle says a FIXED constraint (such as MUST START ON, MUST FINISH ON, START NO LATER THAN or FINISH NO LATER THAN) is present on that task.
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A blue triangle says a UNFIXED constraint (such as START NO EARLIER THAN or FINISH NO EARLIER THAN) is present on that task.
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A red triangle in the top left hand corner shows that there a Risk Log entry associated with that task.

A blue triangle in the bottom left hand corner shows that there a Issue Log entry associated with that task.

A diamond shape in the centre of the cell shows that an ALERT is present.
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A green diamond shows an ALERT that is present  - but is not signalled as a warning. (Date constraints are input using the View menu, Task Form – Links, constraints TAB)
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A red diamond shows an ALERT that is present and is signalled as a warning that the task does not meet the alert status.

Control click – random row selection
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Currently, you can select a continuous range of rows, by dragging down the ID (or Row) column or using Shift click (ie. Click on first ID and then holding the shift key down – the arrow up key used for capitals) and clicking on the last ID in the range.

Now it is possible, by holding the Control key down continually, click on the ID numbers which you wish to select. It will highlight the rows as opposite.

Then you can perform such features as follows to the rows selected …

	· properties

	· shift project

	· auto link

	· cut

	· copy

	· paste

	· clear

	· insert row

	· format cells – background and font

	· Indent/outdent
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Comments

Comments can be added to any row. Right click on the ID or Row number and select Insert Comments. Multiple lines can be saved in the comment window.
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Once saved by clicking on OK, the comment for any task, can be displayed on-screen by clicking on the ID (or Row number) and holding the left mouse down. 
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A box will appear showing data regarding the task and at the bottom will be all the comments text.

The text can be seen on it’s own, by right clicking on the ID and selecting Edit Comment.

It is possible to see an indicator (yellow triangle) if you insert the Information column, by clicking on the [image: image9.png]


 icon on the toolbar. This inserts a column next to the ID column.

You can print the comments on their own, by File menu, Print task comments or you can print them at the end of the barchart on a separate sheet by File menu, Print and click a tick in Print task comments.

Alert dates

Alert Dates are useful for users that update their projects to reflect revised new task start/end dates and want Project Commander to warn if a task is starting/ending too early/late. The warning will appear continually at start up of the file unless resolved.
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Alert Dates are input using the View menu, Task Form – Links, constraints TAB.
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There are 4 alerts …
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Early start - an alert message/icon is triggered if the task start date is before this date.

Late start -  if task start date is after this date.

Early finish - if the task end date is before this date.

Late finish -  if task end date is after this date.

A diamond shape in the centre of the cell shows that an ALERT is present.
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A green diamond shows an ALERT that is present  - but is not signalled as a warning.

A red diamond shows an ALERT that is present and is signalled as a warning that the task does not meet the alert status.
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When you enter an alert date in the Task Form, an Alert warning message will immediately appear on-screen, if the alert is triggered. 
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Once added, the alert can be seen also by clicking on the ID Number and holding the left hand mouse button down.

Note- only one alert can be placed on each task.
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Each time you start up the file, a warning message will show for Alerts activated. At this stage, you can ask to see a filter report on-screen by clicking on SHOW TASKS or go direct to the whole plan by clicking CLOSE.

If you choose to Show the Alerts, you will get a filtered view, and all tasks that do not have Alerts or activated Alerts.

Then to return to a unfiltered view (ie see all tasks), select Tools menu, Filter, All tasks.

Note – you will see that once you have filtered a view, then a message appears at the top of the page under the project title.
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In order to switch this off, select, the Format menu, Title and click OFF the tick for Show Filter/Sort Description.

Also it is possible to view all task bars and show the bars that are effected by Alerts without having the Information column present on screen. Select the View menu, Colour Chart By, Alert. It will show activated alerts in red, unactivated alerts in green and all other bars in white.
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In order to revert the colouring system back, Select the View menu, Colour Chart By, Task.

Issues

A log of issues can be stored with the file and viewed and printed separately. Each issue can be associated with more than one task. The design of the Issue Log follows recommendations of Prince 2.

To enter an issue, select the View menu, Risk/Issues, Issue Log. The Issue Log window can be moved and resized and stays on top of the screen until closed.
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Click on the New Document icon

· Ref 

This field has been designed for numerics and will increase the number by 1 when you create the next issue entry. However, you can edit this box and enter any alphanumeric entry as a unique reference number.
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Issue Type
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There are 3 options..

RFC is a Request for change.

Off-Spec is a change that was not included in the original project.

General covers all other options.

· Date identified

The current date is generated here – but can be changed if the issue was entered later.

· Title

This is used in the summary Issue Log window – so is important to describe the issue to identify it – only the first 30 characters appear in the window
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· Description

You can enter a full description (especially for printing)

· Owner

The name or initials of the person/department/company responsible for the resolution of the issue.
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· Status

There are 4 status types ..

Active – default for new issues.

Closed – means the issue has now ceased.

Ongoing – means that the issue will continue to appear throughout the project.

Not active – the issue has been recorded for the future and is not to be taken into account yet.

· Status Date

The current date is generated here – but can be changed if the issue status was entered later or with a future active date.

· Progress

A full history of progress of how the issue is being dealt with.

· Tasks

This is generated by the system and displays the number of tasks associated with this issue. Until issues are linked to tasks (see below), then this number will remain zero.
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ICONS
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New issue
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Edit highlighted issue (alternatively – double click on any issue listed.
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Delete currently highlighted issue in the list.
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Print the current list using the Print settings on the [image: image25.png]


 icon.
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Save the Issue log to a text file (RTF) to view in Word, etc.
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Link a single or multiple highlighted task on the chart (using the ID/Row column) to the highlighted risk in the list.

Multiple tasks on the chart can be highlighted by holding the CONTROL key down and clicking on the ID/Row No. of each task. To highlight a range of consecutive rows, hold the SHIFT key down and clicking on the ID/Row No. of the first and last task.
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If the INFORMATION column is switched on, then a blue triangle will appear against each selected task . In this example, the TASKS column on the list will show that the particular risk is linked to 2 tasks.
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In order to link the highlighted risk to another task, click on the ID number on the chart and click on this icon.
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To delete all links to tasks for that issue, highlight the Issue and click on this icon. A message will ask you to confirm by saying YES.

[image: image88.png]View Format Tools Options  Resol

2Zoom,
Freeze Panes

+ Taskform crieT
Risksfissues »
Change log
VewBy. »
Colour chart by »
Network diagram

Resource sheet
v Bsic

Resource Chart

chart

Task Dates

Percent Complete:

Baseline

Risk

derts

Cost Estimates

cost

Muliproject views:
More views,

Define.

Showide »
Tool bars >



[image: image33.png]&





To see which tasks are linked to any Issue, click on this icon and on the chart, it will highlight the tasks in the ID column of the tasks effected.
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The Issue list can be filtered using the drop down box. The default is to show all Issues, but they can be selected using issues with an Active, Closed or Ongoing status.
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This icon displays the Print settings

Risks

A log of risks can be stored with the file and viewed and printed separately. Each issue can be associated with more than one task. The design of the Risk Log follows recommendations of Prince 2.

To enter a risk, select the View menu, Risk/Issues, Risk Log. The Risk Log window can be moved and resized and stays on top of the screen until closed.

Click on the New Document icon

· Ref 

This field has been designed for numerics and will increase the number by 1 when you create the next entry. However, you can edit this box and enter any alphanumeric entry as a unique reference number.


· I (for Impact)

There are 3 possible entries (the default is Medium)
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· Category

There are 3 possible entries (the default is Project)
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· Date Identified

The current date is generated here – but can be changed if the risk was entered later.

· P (for Probability)

There are 3 possible entries (the default is Medium)
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· Owner

The name or initials of the person/department/company responsible for the resolution of the risk.

· Title

This is used in the summary Risk Log window – so is important to describe the issue to identify it – only the first 30 characters appear in the window
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· Description, Solution and Contingency

You can enter a full descriptions for each (especially for printing)

· Status

There are 4 status types ..

Active – default for new issues.

Closed – means the issue has now ceased.

Ongoing – means that the issue will continue to appear throughout the project.

Not active – the issue has been recorded for the future and is not to be taken into account yet.

· Status Date and Target Date

The current date is generated here – but can be changed if the Risk status was entered later or with a future active date.

· Progress

A full history of progress of how the issue is being dealt with.

· RAG 

There are 3 status types ..
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· Tasks

This is generated by the system and displays the number of tasks associated with this issue. Until issues are linked to tasks (see below), then this number will remain zero.
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ICONS
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New issue
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Edit highlighted issue (alternatively – double click on any issue listed.
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Delete currently highlighted issue in the list.
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Print the current list using the Print settings on the [image: image45.png]


 icon.

[image: image46.png]



Save the Issue log to a text file (RTF) to view in Word, etc.
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Link a single or multiple highlighted task on the chart (using the ID/Row column) to the highlighted Risk in the list.

Multiple tasks on the chart can be highlighted by holding the CONTROL key down and clicking on the ID/Row No. of each task. To highlight a range of consecutive rows, hold the SHIFT key down and clicking on the ID/Row No. of the first and last task.
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If the INFORMATION column is switched on, then a red triangle will appear against each selected task . In this example, the TASKS column on the list will show that the particular risk is linked to 2 tasks.
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In order to link the highlighted Risk to another task, click on the ID number on the chart and click on this icon.
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To delete all links to tasks for that issue, highlight the Issue and click on this icon. A message will ask you to confirm by saying YES.
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To see which tasks are linked to any Risk, click on this icon and on the chart, it will highlight the tasks in the ID column of the tasks effected.

The Risk list can be filtered using the drop down box. The default is to show all Issues, but they can be selected using issues with an Active, Closed or Ongoing status. 
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This icon displays the Print settings

Change Log

A log of changes can be stored with the file and viewed and printed separately. No entries can be deleted once entered – to ensure the audit trail.

The extent of the log, depends totally on if it is used extensively by all users of the file.

To enter on the log, select the View menu, Change Log. The window can be moved and resized and stays on top of the screen until closed.

Click on the New Document icon
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· Ref 

This field has been designed for numerics and will increase the number by 1 when you create the next entry. However, you can edit this box and enter any alphanumeric entry as a unique reference number.

· Date identified

The current date is generated here – but can be changed if the issue was entered later.

· Author

Person entering the log.

· Description

You can enter a full description (especially for printing)

· Approved by

Person authorising entry

ALL FIELDS MUST BE ENTERED to allow you to save the entry.


No entries can be deleted once saved – but can be disregarded by double clicking and tick the DISREGARD box.

ICONS
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New issue
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Print the current list using the Print settings on the [image: image59.png]


 icon.
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Save the Issue log to a text file (RTF) to view in Word, etc.

The Log list can be filtered using the drop down box. The default is to show all Changes, but they can be selected using only active changes (ie Don’t show disregarded)
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The Log list can be sorted using the drop down box. The default is to show all Changes in the order entered, but they can be sorted using the Date entered.
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This icon displays the Print settings
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Network Diagram

You can view a Network diagram for linked tasks. The window is constructed in such a way that the only the ID numbers are shown in boxes linked and a full list of tasks down the right hand side and the Task Form at the bottom.
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Each compartment of the window is synchronised on the same task. You can choose the highlighted task by …

· Click once on a box

· Click on a task in the task list

· Click on NEXT/PREVIOUS buttons in the Task Form

It is possible to enter new links in this window to existing tasks by highlighting the ID number on the list and entering a Predecessor or Successor.

If you wish to enter a new task, click on the last task on the list and then click on NEXT on the toolbar and enter a Name, Start date & Duration (as normal)

[image: image66.png]| 1
D10 Name] S0 Tl Duston] = Frih 005 =] | Previous | [ew
Project Outine] I Ovenide curstion Actual %] = 100%]





If the network diagram area is insufficient to contain all the tasks, a scroll bar will appear on the bottom and right hand side of the diagram. If the list area is not long enough, a vertical scroll bar will appear.

If there a large number of tasks/links, you can highlight any task and the diagram will centralise the network graphic around that task in the centre.

The Network Diagram is only available as a on-screen report (it cannot be printed out). However, the Link List can be printed still in order to report all links in hard form.

Extra NEW feature in 6.5 – Build 2315 and above   Task List

When you start up Project Commander, it defaults into WYSIWYG mode – which means you see each page on the screen as it would print. 

Now if you want to enter tasks (and link them) in a list, you can select the VIEW menu, TASK LIST. This opens up a list of up to 999 consecutive rows with the same fields as the Basic View. Note it is not possible to Zoom this screen.

Two messages appear. Click on YES. As the message says, the print is disabled in this mode (you will need to exit this View and choose another View in order to set the LINES PER PAGE and determine the number of pages required)

The whole project timescale is fitted by default to one screen’s width. If you wish to spread the timescale over several screens horizontally, change the 1 to a higher figure.

Linking with the mouse

Normally you cannot link beyond the bottom of the screen or across pages. In the TASK LIST view, if you have a mouse with a scroll wheel, you can start to draw a link (key your finger pressed down on the left hand mouse button) and then with a second finger, turn the wheel forward to scroll down the chart and release off when linked to the other bar. 
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To print

In order to return to the normal WYSIWYG mode and to be able to print, you must choose another View.
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